Excel 2 v.3 Greenwood Public Library

Excel 2: Formulas, Charis, & More
Class Guide

Instructor: Susan Jerger

Part 1: Excel 1 Recap

1.1 Formatting Refresher
Below is a picture of the Home tab of the Ribbon which contains most, but not all, of the features

we’ll go over in class today.
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Exercise 1: Open the Grand Opening Contacts spreadsheet (in Excel2Class Spreadsheest.xlsx). Spruce
up the spreadsheet with colors and borders. Merge & Center the “Grand Opening Contacts” across
the top of the table.

Part 2: Sorting & Filtering
2.1 Sorting

You can easily sort your data alphabetically, chronologically, or numerically...and even by color.
Sorting can be Ascending (A-Z) or Descending (Z-A). If you have a Header Row (a top row that labels
the data of your table), it is a good idea to format this row to stand out from your actual data.
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Exercise 2: In the Grand Opening Contacts spreadsheet... =AY @
e Place the cell pointer on one of the last names in column A. 5. fons rnas
e Click on Sort & Filter and then ! s

Exercise 3: In the Grand Opening Contacts spreadsheet...

e Place the cell pointer on any cell within A4 to K a5
e Click on Sort & Filter>Custom Sort e L
e Choose to sort by Last Name and then First Name i 5
and then Business on the window that pops up. - .
e Click OK.
Exercise 4: In the Grand Opening Contacts spreadsheet... =

e Change the background color of 5 Last Name cells fthat are not al)/next to each other
alphabetically). Click on just one cell in your tab
e Click on Sort & Filter->Custom Sort
e Add another level and make sure it is at the top. Sort it by ast Name and
sort on Color.Choose the Order and click OK
NOTE: You can also sort horizontally if needed by clicking on Options in the Sort box

and then choosing the Sort left to right orientation.
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2.2 Filtering

Filtering is a quick and easy way to hide data so that you can see only the relevant data you need.
It is a cinch to turn off and on. -
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Exercise 5: In the Grand Opening Contacts spreadsheet...
e Place the cell pointer on any cell within A4 to K26

e Click on Sort & Filter->Filter
e On the spreadsheet, click on the down arrow to the right of City and T I
select only Greenwood to limit your list. —> ENmEC
e Click OK L o L
To turn off filtering, simply click on Sort & Filter DFilter M Ja¢

v

Part 3: Altering Your View o]

3.1 Freezing Panes
You can freeze panes—sections of the spreadsheet—so you can easily view them even when you
scroll up and down/left and right. Freezing Panes does not affect how your spreadsheet prints.

Exercise 6: In the Grand Opening Contacts spreadsheet...
e Click on cell A4.
e Click on View.
e Click on Freeze Panes>Freeze Panes
e Now scroll down and see if Rows 1-3 stay in place
Click on Freeze Panes 2UnFreeze Panes to turn this feature off.

IMay [June [July [Auaust  [September [October

Part 4: Formulas & Functions
4.1 Formula Basics

Formulas are equations that perform calculations on values in your spreadsheet and always start
with an equal sign (=). Here are the symbols/operators for simple calculations:

+ Addition - Subtraction * Multiplication / Division

Ordering = Excel calculates from left-to-right with multiplication and division always completed first
(use () to change this order)
Copying Formulas = You can copy & paste or use AutoFill to easily copy formulas from cell to cell.

4.2 Functions

Functions are prewritten formulas—you just need to supply the value(s) and not the operator(s).
The same rules for formulas apply to functions. Some other info:
% You can calculate ranges of cells using the colon (:).
You can use a comma (,) to separate cells you want to include that are not in a range.
If you don’t highlight what cells you want to include in a function, Excel automatically looks
above the cell you’re at to locate numbers. If nothing is there, it will look to the left then the
right.

X/

A

K/ K/
LG X4

Exercise 8: AutoSum X is the function we used in Excel 1. On the Widget Sales Data spreadsheet...
e Select Row 15 and click Wrap Text in the Ribbon.
e Click on cell B13.
e Click on the AutoSum shortcut at the top right.
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Click the checkmark at the top or Enter.
Tally the rest of the months as well as column N using AutoSum (and AutofFill).
Use AutoSum in cells N4 to N12 to tally each widget type.

NOTE: If ##### appears in a cell, widen the column so the number will fit.
HINT: You can automatically widen all columns in your spreadsheet. We won’t use it for this
exercise, but here’s how:

4.3 MAX, AVERAGE, & Percentage

Click on the empty gray rectangle to the left of column A.
Click on Format—-> Autofit Column Width

X AutoSum ~ _1}

We will explore other functions (there are hundreds of them!) as well as T sum
create a percentage formula. You can get to all functions in Excel by clicking fuerage ft

on AutoSum->More Functions or by clicking on the Formulas tab of the Ribbon e

Count Numbers

(be sure to not be on a cell that has a function in it when you do thk)\) in b

Exercise 9: On the Widget Sales Data spreadsheet...

Maore Functions...

Put the cell pointer on B16.

Click on the arrow next to AutoSum near the top

Find the MAX listing and click on it.

Next, a formula will show up in your spreadsheet with cells Excel thinks you want to use. Make
sure they are B4 through M4. If they aren’t, highlight those cells.

Click the checkmark or press Enter.

Calculate the MAX monthly sales figure for the other colors plus the Total

Exercise 10: On the Widget Sales Data spreadsheet...

Put the cell pointer on C16

Click on the arrow next to AutoSum near the top

Find the AVERAGE listing and click on it.

Next, a formula will show up in your spreadsheet with cells Excel thinks you want to average.
They are not the correct ones, so highlight cells B4 through M4.

Press Enter.

Calculate the AVERAGE number for the other colors plus the Total

Exercise 11: On th? Widget Sales Data Khere may be occasions when you need an Absolute Cell \
spreadsheet, we will figure each color’s

Reference (or a combination of Relative and Absolute) so that
Average Monthly Sales percentage of the one or more of the cells in your formula or function never
Average Monthly Total. change...or only change by column or row. “$” symbols indicate
e Put the cell pointer on D16. an absolute reference.
e Type =c16/c25 and press Enter. Example When copied...
e Format the result to a percentage —a4/5b$3 A4 can change; B3 will
by clicking on the % in the Number never change
area of the Home tab ribbon. =a4/Sh3 A4 can change; Column B
e Try to copy this formula into cell will never change but Row
D17. You will notice that this will 3 can
not work since Excel will change the =a4/b$3 A4 can change; Column B
Relative Reference from cell C25 \ can change but Row 3 will /
down to C26 which is blank. To get
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copying and pasting to work, we’ll redo our percentage formula so that the reference to C25 is

partially ABSOLUTE instead of all RELATIVE.
e Go back to cell D16 and type =c16/c$25
e Copy and paste the formula into cells D17 through D24.

4.4 COUNT
COUNT is one function from a group called Count Functions. Its goal is to add up the cells in a
selected range that contain numbers (not text...just numbers).

Exercise 12: On the Widget Orders spreadsheet...
e Clickon cell B16
e Either type =count(b4:b10) or click on the arrow next to AutoSum and choose Count Numbers
(and then highlight B4:B10)
e Use AutoFill on cells C16 to E16.

Part 5: Charts...As Easy As Pie (and Line and Bar.. )

5 1 Chal"tS Bookl - Microso
It is super easy to make charts of a table in Excel using ‘”“"d; ’ jéh p‘ e Dete L Reew e e
the Insert tab menu. The exercise below will demonstrate — " = ﬂn \L“K ® 5 "" ET 'th)

& screenshot «

this feature. ;‘. i B

Exercise 13: Back on the Widget Sales Data spreadsheet...
e Highlight the data range A15 to B24 for our chart.
e Click on the Insert tab and then Column. Choose the first 3-D Column from the dropdown list.
e Notice that three new Chart Tools tabs appear above the Ribbon. These will help you
customize your chart.

[EIN= I |= Bookl - Microsoft Excel h |

m Hal Insert Page Layout Formulas Data Rev ew Design | Layout | Format

[ mz j_l & ¢ ‘, ‘“ “

hﬂpT nplate | Rov
Type Data Chart Layouts

e Click on the Layout tab. Use the Chart Title, Legend, and Data Labels menu to change your
chart if you would like.

e Next, click on the Move Chart option on the Design tab will give you the option to place your
chart in a new worksheet. Let’s do that!

Part 6: Copying & Pasting into Word
6.1 Paste Special

You can conveniently copy an Excel spreadsheet section or chart into Word if you are typing a
report. If you use the Past Special feature, you can make it so that updating the spreadsheet in Excel
will automatically update the copied section/graph in Word.
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Exercise 14: Using the chart from earlier in class...

- Paste Special Px
e Click on the chart once e Cameedy
e Click on Copy or press Ctrl+C.
e Open Word and click on the arrow below Paste. e 5 e

e Select Paste Special. In the box that pops up, choose
Paste Link and Microsoft Excel Chart Object.

® C li C k 0 K . RE @ Inserts the cantents of the Clipbaard as a picture,
T Cly Paste Link crestes a shorkcut to the source file, Changes to the source file will be reflected
Now when you update the chart’s underlying spreadsheet, the e
information will automatically transfer to the Word document.

Part 7: Sparklines - Easy Inserts
7.1 Sparklines

Sparklines (new in Excel 2010) are tiny charts that can show data trends very easily. Here is how
they work:

Exercise 15: Using the Widget Sales Data spreadsheet...

e Click on Cell O3 and type in Graphs. Draw in borders around cells 03-013. e o
o Click on Cell 04. o —
e Click on the Insert tab and then on Line in the Sparklines group. '
e Make B4:M4 the data range and click OK. —

. . . Create Sparklines T |-l
e Use Autofill to copy the sparkline into cells 05-013. S I
e Click on the Sparkline Tools Design tab to mark the High P oo range: 900 &
Point.
o - - N e Choose where you want the sparklines to be placed
— - “_ oin Trst Poin Location Range: | $0%4 @
Edit Line |Column b‘.‘\n_l:lss ourom . D Last Paint M M \/\/ \/\/\ '
Data~ [ Wegative Points [C] Markers o ] | — |

Part 8: Further Help

8.1 HELP!
Excel has a help feature that can aid you in refreshing your memory on certain tasks or by
even learning new tasks. Help can be reached at by clicking the Question mark in the upper
right hand corner. You will most likely be directed to Office.com’s online help, but there is an

offline version if needed.

8.2 Additional Help
Below are some websites that might be of help to you:

www.greenwoodlibrary.us/computer-class - Lists all of the library’s computer classes and includes the
Excel guides and class spreadsheets.

www.inspire.in.gov - Click on the Testing & Education button near the middle of the page (then click
on Career Tools and then Basic Computer Skills—you will need to create a free account)

www.gcflearnfree.org - A great collection of tutorials on a wide array of subjects including Microsoft
Excel 2003-2016.
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www.free-training-tutorial.com - Free tutorial videos on Excel tasks (just be wary of clicking on the

ads)

http://spreadsheets.about.com/

www.customguide.com/cheat-sheets/ - Free cheat sheets for most Office programs 2007-2016.

www.google.com/work/apps/business/products/sheets/ - You can use Google Sheets for free (after
creating a Google account) to practice many of the Excel features we’ve used today.

You can also find help by searching for the function you want to use or the problem you’re having
using your favorite search engine.

Thank you for coming!
Please fill out a Computer Class Survey before leaving.
http://www.greenwoodlibrary.us/programming-survey
(or go to www.greenwoodlibrary.us ->Services & Programs - Computer Survey)

Instructor’s Name: Susan Class: Excel 2
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